【サイトがふっとんだ】 ネームサーバーの変更でドボン

さくらのレンタルサーバ のサービスの一つである『 メールの設定 』 も終わりましたので、いよいよ ムームードメイン サーバーの設定の変更をしていくことになりました。

しかし、ここからが実に大変でした。
今までのは余興の状態。

ゲームで言うと、チュートリアルの状態です。
そんなわけで、この後、今まで舐めプしていた私に次々と問題が降りかかりしました。

スポンサーリンク

【適当にやって死亡】 DNSエラーの恐怖

とりあえず、まず最初にさくらのレンタルサーバのドメイン設定の説明書きを見つつ、サーバーの設定をしてみることにしました。

ドメイン設定の項目の説明書きには、独自ドメインのネームサーバーは

独自ドメイン

プライマリネームサーバー ns1.dns.ne.jp 210.188.224.9
セカンダリネームサーバー ns2.dns.ne.jp 210.224.172.13

で、サブドメインのメールサーバーは、こんな感じになると書かれてありました。

サブドメイン

※サブドメインが「sub」、独自ドメイン「example.jp」の場合

sub IN NS ns1.dns.ne.jp.
IN NS ns2.dns.ne.jp.

これを見て、『 NS 』は恐らく『 ネームサーバー 』と言う意味だと思いました。
なので、ムームードメインのムームーDNSで種別に『 NS 』と書き、ネームサーバーには『 ns1.dns.ne.jp 』と『 ns2.dns.ne.jp 』と書こうと思いました。

でもムームードメインのカスタムDNSの種別の選択肢には、『 NS 』と言う項目はありませんでした。

分からないと思った時にちょっとでも調べ直したらよかったのですが、ここで私のズボラ癖が発症。

何と、愚かな私はライブドアブログへの移転の時のことを思い出し、種別を 『 CNAME 』にして内容を『 ns1.dns.ne.jp 』『 ns2.dns.ne.jp 』に設定してしまいました。

そしてこの直後、当然のごとくDNSエラーが出てしまい、サイトが表示されなくなってしまったのでした。


【最初からやれ】 調べなおして設定しなおした

そんなこんなで、私のズボラ癖が功を奏し、見事DNSエラーで何も表示されなくなった可哀想な我がサイトたち。
そんなサイトたちを救うべく、とりあえずは元の ヘテムル に設定を戻しました。

そして、その間にムームードメインでさくらのサーバーを使う方法を調べたのでした。
するとすぐに方法が見つかりました。

どうやら、ネームサーバーの設定画面で、『 他社のサーバーを使う 』項目を選択し、『 ns1.dns.ne.jp 』『 ns2.dns.ne.jp 』を入力すれば良いようでした。
(実に簡単)


さくらのレンタルサーバーでムームードメインの独自ドメインを設定する方法

ムームードメインで取得したドメインをさくらインターネットで使う方法


そこで早速やってみたのですが、結果は見事に大外れ。\(^o^)/
何も表示されなくなってしまいました。
(何が悪かったのかなー (つд⊂))

私が「あるぇ〜?(・3・)」とか言ってるその間も、DNSエラーとか404エラーは出続けています。
(何故か、サイトによってエラーは2種類ありました)

とりあえず、またヘテムルに設定を戻し、何が悪かったのか再検証してみることにしました。

そして、調べていくうちに、
『 もしかしてムームーDNSのカスタム設定をちゃんとやらないとダメなんじゃないだろうか? 』

そんな疑問が私の脳内に湧いてきました。

もう、合計で10時間以上エラーでサイトが表示されない状態に陥っています。
これ以上の失敗は許されません。
(とか言いつつ、この後もさらに失敗しましたが)

でも、やらないと何も始まらないので、とりあえずムームーDNSのカスタム設定をやってみることにしました。


【お前は何を考えているんだ?】 IP違いで再ドボン

そんなわけで、ムームーDNSを設定しなおすことに決めた私。
でも、ライブドアブログの時のようなCNAMEではダメだと言うのはわかりました。

そこで、再度調べなおしてみたところ、さくらの場合は 『 種別 』 は 『 A 』 にしないといけないと言うことがわかりました。
で、Aにする場合はホスト名ではなくIPアドレスを入力する必要があると。。。

何?IPアドレス使う?
そう言えばあったね、IP! (´・∀・`)
こんなこともあろうかと思って、ちゃんと記録してたんだよ、私。( ´艸`)

と言うわけで、ドメイン設定のところにあった 『 210.188.224.9 』 を設定したのでした。
でも、実はこれは間違いでした。

実は、『 サーバー情報の表示 』( コントロールパネルサイドバーにリンクがある )のところにある 『 サーバーに関する情報 』 を見る必要があったのです。

そこの 『 使用中のサーバーのIPアドレス 』 が表示されていますので、それを入力するのです。

でも、これって書いてあったんですよね。
参考にさせて頂いたマニュアルページに。(;´_`;)

じゃあ、何で間違えたのか?
アホな上にズボラだからです。

と言うわけで、案の定、またしても私のサイトは何も表示されない白紙状態になってしまったのでした。
(これで何回目よ)

そんなわけで、慌てて参考にさせて頂いたマニュアルページを確認しなおしました。
すると、IPアドレスが違っていることを発見
(発見って言うか、ただ単に前にちゃんと見てなかっただけなんですけどね。( ̄m ̄))

その後すぐに、IPアドレスを変更したのでした。

でも、問題はこれで終わりませんでした。
さらなる問題が発生したのでした。

その問題とは?
それはまた、次ページで。


次ページ

【開けてビックリ】 PHPのinclude ができなくなった

前ページ

【作業開始】 さくらのレンタルサーバの設定を変更した


スポンサーリンク